Home / Community / Forum / Poker Forum / Poker Ausbildung /

SQL verbindungsproblem

Alt
Standard
SQL verbindungsproblem - 05-06-2009, 14:33
(#1)
Benutzerbild von Red Bull SL
Since: Oct 2007
Posts: 135
Hallo,

ich versuche mich gerade daran eine Pokersoftware zu benutzen.

Brauche dafür postgreSQL was ich installiert habe.
Kann auf Pokerhands und bei PT3 leider keine Verbindung zu dem SQL herstellen. PW name stimmen.

Selbst wenn ich bei postgre auf sql shell gehe kommt folgende Fehlermeldung.


"psql konnte nicht mit dem server verbinden connection refused (tausende ziffern)"

"Läuft der Server auf dem Host "localhost" und akzeptiert er tcp/ip-Verbindungen auf port 5432?

Was stimmt da nun nicht?
 
Alt
Standard
05-06-2009, 14:59
(#2)
Gelöschter Benutzer
Du findest im Programmordner von postgresql 2 Textdateien unter
\PostgreSQL\8.3\data.
Die erste Textdatei nennt sich pg_ident. Öffne die mal bitte mit einem Editor. Wenn da im letzten Absatz sowas steht:
Zitat:
No map names are defined in the default configuration.
brauchst den nicht hier zu posten.

Poste bitte den Inhalt der pg_hba.
 
Alt
Standard
05-06-2009, 15:23
(#3)
Benutzerbild von Red Bull SL
Since: Oct 2007
Posts: 135
ja so ein satz steht unten in der ersten datei
hier den anderen Ordner

# PostgreSQL Client Authentication Configuration File
# ================================================== =
#
# Refer to the "Client Authentication" section in the
# PostgreSQL documentation for a complete description
# of this file. A short synopsis follows.
#
# This file controls: which hosts are allowed to connect, how clients
# are authenticated, which PostgreSQL user names they can use, which
# databases they can access. Records take one of these forms:
#
# local DATABASE USER METHOD [OPTION]
# host DATABASE USER CIDR-ADDRESS METHOD [OPTION]
# hostssl DATABASE USER CIDR-ADDRESS METHOD [OPTION]
# hostnossl DATABASE USER CIDR-ADDRESS METHOD [OPTION]
#
# (The uppercase items must be replaced by actual values.)
#
# The first field is the connection type: "local" is a Unix-domain socket,
# "host" is either a plain or SSL-encrypted TCP/IP socket, "hostssl" is an
# SSL-encrypted TCP/IP socket, and "hostnossl" is a plain TCP/IP socket.
#
# DATABASE can be "all", "sameuser", "samerole", a database name, or
# a comma-separated list thereof.
#
# USER can be "all", a user name, a group name prefixed with "+", or
# a comma-separated list thereof. In both the DATABASE and USER fields
# you can also write a file name prefixed with "@" to include names from
# a separate file.
#
# CIDR-ADDRESS specifies the set of hosts the record matches.
# It is made up of an IP address and a CIDR mask that is an integer
# (between 0 and 32 (IPv4) or 128 (IPv6) inclusive) that specifies
# the number of significant bits in the mask. Alternatively, you can write
# an IP address and netmask in separate columns to specify the set of hosts.
#
# METHOD can be "trust", "reject", "md5", "crypt", "password", "gss", "sspi",
# "krb5", "ident", "pam" or "ldap". Note that "password" sends passwords
# in clear text; "md5" is preferred since it sends encrypted passwords.
#
# OPTION is the ident map or the name of the PAM service, depending on METHOD.
#
# Database and user names containing spaces, commas, quotes and other special
# characters must be quoted. Quoting one of the keywords "all", "sameuser" or
# "samerole" makes the name lose its special character, and just match a
# database or username with that name.
#
# This file is read on server startup and when the postmaster receives
# a SIGHUP signal. If you edit the file on a running system, you have
# to SIGHUP the postmaster for the changes to take effect. You can use
# "pg_ctl reload" to do that.

# Put your actual configuration here
# ----------------------------------
#
# If you want to allow non-local connections, you need to add more
# "host" records. In that case you will also need to make PostgreSQL listen
# on a non-local interface via the listen_addresses configuration parameter,
# or via the -i or -h command line switches.
#



# TYPE DATABASE USER CIDR-ADDRESS METHOD

# IPv4 local connections:
host all all 127.0.0.1/32 md5
# IPv6 local connections:
#host all all ::1/128 md5

Geändert von Red Bull SL (05-06-2009 um 15:25 Uhr).
 
Alt
Standard
05-06-2009, 15:32
(#4)
Gelöschter Benutzer
Yepp- die Authentifizierungsmethode stimmt nicht.
Plätte die postgresql nochmal komplett bitte
1. Ganz normal über Systemsteuerung-Software-entfernen-postgresql

2. \programme\postgesql\8.4\data kompletten Ordner löschen

3. Den User 'postgres' löschen
Systemsteuerung-Verwaltung-Computerverwaltung-Lokale Gruppen und Benutzer-Benutzer-postgre LÖSCHEN

4. \Dokumente und Einstellungen\postgres LÖSCHEN

5. \Dokumente und Einstellungen\%USER%\Anwendungsdaten\postgresql
LÖSCHEN

6. Nochmal mit 'Suchen' nach Dateien 'postgre*' suchen, wenn Du da noch etwas findest- löschen

Bei der Neuinstallation vergibst Du bitte kein Passwort- dann ist die Authentifizierung 'trust' und, falls Du Vista benutzt, schalte vorher das UAC aus
 
Alt
Standard
05-06-2009, 15:46
(#5)
Benutzerbild von Red Bull SL
Since: Oct 2007
Posts: 135
unter Computerverwaltung hab ich keine lokale gruppen und benutzer usw.


sorry mir raucht grad der Kopf wo ist nun wieder "Dokumente Einstellungen"

hab XP

Geändert von Red Bull SL (05-06-2009 um 15:51 Uhr).
 
Alt
Standard
05-06-2009, 15:58
(#6)
Gelöschter Benutzer
Kein Problem- vielleicht wirds so deutlicher:

 
Alt
Standard
05-06-2009, 16:01
(#7)
Benutzerbild von Red Bull SL
Since: Oct 2007
Posts: 135
hab das mit dokumente schon gefunden i trottel

Aber bei computerverwaltung steht nix von den lokalen gruppen und benutzer der gesammte punkt felt da

ich hab unter system nur folgende Punkte:

Ereignisanzeige
Freigegebene Ordner
Leistungsprotokolle...
Geräte Manager
 
Alt
Standard
05-06-2009, 16:06
(#8)
Gelöschter Benutzer
- Arbeitsplatz
- rechte Maustaste
 
Alt
Standard
05-06-2009, 16:18
(#9)
Benutzerbild von Red Bull SL
Since: Oct 2007
Posts: 135
sorry ich hab ja alles soweit hinbekommen aber bei arbeitsplatz rechtsklick oder auch in der Computerverwaltung hab ich die blöden benutzer oder gruppen nicht.

bzw was ist nach rechts klick wo soll ich da hingehen? sag stell ich mich so doof an *lach*

Soll ich es ohne das zu löschen mal installieren?
 
Alt
Standard
05-06-2009, 16:25
(#10)
Gelöschter Benutzer
Sch.... Vista.
- Systemsteuerung
- Benutzerkonten hinzufügen/entfernen

Hast Du den Menüpunkt, dann entferne postgresql darüber